Port-atari archive

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index][Old Index]

Re: bootloader issue

Sysinst from HEAD runs installboot.  Here's the command line:
/usr/mdec/installboot -v /dev/rsd0c

And the output:
installboot: Cannot stat /netbsd, no bootversion check done
Primary   boot loader: /usr/mdec/std/sdboot
Secondary boot loader: /usr/mdec/std/bootxx
Boot block installed on /dev/rsd0c (sector 0)
Boot preference set to NetBSD.

Now, after this is installed of course I get the "Halting..." message, so I now have gone back to run installboot from 1.6.1. /boot.atari is still the one from HEAD so we have the mismatch. I just tried fixing the mismatch by dropping the boot.atari from 1.6.1 onto the root of the drive. And... it worked! Well, sort of...

The HEAD kernel boots up off the drive and here's what I get:

Two possibilities immediately come to mind:
- Running the 1.6.1 installer slightly corrupted the drive. In truth, I didn't _just_ run the 1.6.1 installboot. That alone fails. (Yeah, I know I should have written the exact failure down. I can go get it no problem if necessary.) I actually ran through the first part of the 1.6.1 install and picked the option to preserve the existing filesystem. Installboot flashes by, too quick to see what the command line parameters are. But from past experience I know installboot does succeed in this scenario, which is all I need. In any case, this whole process of going through part of the 1.6.1 install procedure after the HEAD install could have messed up the super blocks. - It could just be the next blocker on the road to a working NetBSD HEAD install. This is the furthest we've gotten with a recent kernel on the TT030.

I'm going to start reading up on fsck_ffs to see if I can fix the issue with the super blocks. If anybody has a good fsck_ffs command line to use, let me know! I would be kind of an annoying install procedure to have to use 1.6.1 to fix the bootloader, but if it works that's better than nothing.

David Ross

----- Original Message ----- From: "David Ross" <dross%pobox.com@localhost>
To: "Izumi Tsutsui" <tsutsui%ceres.dti.ne.jp@localhost>
Cc: <tjamaloo%gmail.com@localhost>; <abs%NetBSD.org@localhost>; <port-atari%NetBSD.org@localhost>; <tsutsui%ceres.dti.ne.jp@localhost>
Sent: Saturday, January 03, 2009 9:44 PM
Subject: Re: bootloader issue

When I ran installboot from 1.6.1 on top of the HEAD install, I could get to
the second stage bootloader. But the second stage bootloader crashed, I

Exact messages might help. ("crash" is too ambiguous...)

I was just experimenting and I didn't write it down. I wasn't too surprised when I saw it after I checked and saw the /boot.atari was still the one from HEAD, so there would be a mismatch between the old primary/secondary and the new tertiary loader. I'm planning to go back and try this scenario with the old /boot.atari. Before I do that I'll get a copy of the error when there's the mismatch.

Could you try the latest installboot with "-v" option?
This is what sysinst does so I see the output a lot but I don't have it written down. I will get it on a HEAD install.

David Ross

Home | Main Index | Thread Index | Old Index