Port-arm archive

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index][Old Index]

Re: i2c working on BeagleBone?

On Sun, 2 Apr 2023 at 06:05, Chris <sekiya%netbsd.org@localhost> wrote:
> On Sun, Apr 02, 2023 at 11:27:28AM +0200, Radoslaw Kujawa wrote:
> > I am positive it worked before FDT changes. I remember playing around with various sensors and even testing newly written I2C drivers with the original white BB.
> Thanks for the confirmation; now I have a better idea what I'm dealing with.
> What version were you working with, so that I can better bisect the code?
I just downloaded, built and tried an 8.2 kernel (on BB white). It
does not detect iic1 until I add this:
tiiic1        at obio1 addr 0x4802A000 size 0x1000 intr 71

The ti_iic driver silently fails to configure the I2C1 pads. It should
be looking for "SPI0_CS0" and "SPI0_D1" but is searching for
"I2C1_SCL" and "I2C1_SDA" instead.
I will try to fix this and do more testing, but I think it never
worked unmodified on 8.2. The device tree came in version 9 (See:


Home | Main Index | Thread Index | Old Index