Port-arm archive

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index][Old Index]

Problems booting NetBSD 9.0 on ODROID-C1


I am trying to use NetBSD 9.0 on my ODROID-C1 but with no luck.

I am following these instructions to try to boot NetBSD 9.0 on my ODROID-C1:

I download the image "armv7.img" for NetBSD 9.0:

I am using the pre-built U-Boot binaries linked in the instructions:

And I follow the instructions to copy them within the .img file. Regarding the "boot.ini" file, I have tried several configurations:
* unmodified boot.ini
* modify boot.ini with the lines from the instructions
* playing with different permutations of the above configurations, i.e. adding console=fb
For both configurations I get a blank purple screen (the default one showed by ODROID-C1) when starting the system. No output of any kind.

I also tried one of these pre-generated images:
That time I was luckier and the system started to boot up, but hanged out when trying to auto-resize the SD partition. I checked the boot.ini file of this image and it is exactly the same one I get after modifying the armv7.img, with no further manual modification of the boot.ini.

Not sure what I am missing or how to troubleshoot this, any suggestion is more than welcome.

Thanks in advance!


Home | Main Index | Thread Index | Old Index