Port-arm archive

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index][Old Index]

Re: pi zero

On 8 Aug 2019, at 11:37, Patrick Welche <prlw1%cam.ac.uk@localhost> wrote:

On Tue, Aug 06, 2019 at 04:44:35PM +0100, Patrick Welche wrote:
On Fri, Aug 02, 2019 at 01:09:25PM +0100, Patrick Welche wrote:
On Fri, Aug 02, 2019 at 12:50:47PM +0100, Patrick Welche wrote:
On Fri, Aug 02, 2019 at 09:03:17PM +0900, Rin Okuyama wrote:
Both 9.0_BETA and 9.99.2 boot fine for my Zero W.

Sorry for having been imprecise: turns out it is a W
"Raspberry Pi Zero W V1.1"

Given that I tried nyftp images to rule out local build issues, it's
interesting that it works for you. I will try again.

Tried again with


and got the rainbow. I'll start bissecting...

It seems I actually have 3 states:

- rainbow
- blank screen (and once with a few coloured dots)
- boot with green kernel messages

Haven't quite finished the (lengthy) bisection, but at the moment it looks
like the blank / boot boundary is going to coincide with the appearance
of dtb files. (I do cp  bcm2835-rpi-zero.dtb bcm2835-rpi-zero-w.dtb
as part of the process, just in case...)

Thanks for working on bisecting this.

Raspberry Pi got FDTised around this time


Iirc, the  rainbow screen means no kernel/dtb is loadable by the firmware.

Can you check if the dtb copy gives you a blank screen, ie no rainbow just after these changes. Serial console will help here if you have one

The rainbow I suspect is from some other change (much) later on.


Home | Main Index | Thread Index | Old Index