Port-arm archive

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index][Old Index]

earmv7hf panic

I updated a olimex lime2 board (allwinner A20) with an up to date kernel,
and it panics with:

[   4.6949594] panic: VFP fault at 0x80073d78 in non-user mode
[   4.6949594] cpu1: Begin traceback...
[   4.7049580] 0x99eebb9c: netbsd:db_panic+0x14
[   4.7049580] 0x99eebbb4: netbsd:vpanic+0x194
[   4.7149586] 0x99eebbcc: netbsd:snprintf
[   4.7149586] 0x99eebc7c: netbsd:vfp_attach
[   4.7249615] 0x99eebd34: netbsd:undefinedinstruction+0x10c
[   4.7249615] 0x99eebdf4: netbsd:address_exception_entry+0x5c
[   4.7349674] 0x99eebe54: netbsd:pcu_load+0x17c
[   4.7349674] 0x99eebef4: netbsd:vfp_handler+0x50
[   4.7449618] 0x99eebfac: netbsd:undefinedinstruction+0x10c
[   4.7549647] cpu1: End traceback...
Stopped in pid 2.1 (sh) at      netbsd:cpu_Debugger+0x4:        bx      r14

(it can also happen on cpu0).

Another board with a different userland doen't have this problem.
Also, rebooting with an older kernel avoid the problem.
I tried booting from tftp or from local sdcard, with uboot or EFI, with
the same result.
Any idea ?

Manuel Bouyer <bouyer%antioche.eu.org@localhost>
     NetBSD: 26 ans d'experience feront toujours la difference

Home | Main Index | Thread Index | Old Index