Port-arm archive

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index][Old Index]

installing netbsd on the pinebook 1080p, issues i saw., etc.

OK, here's a dump of all the info i have about the pinebook 1080p:

- the "arm64.img.gz" built by "build.sh release" is not complete
  for most systems, including the pinebook.  it's missing u-boot.
  this is the additional service Jared has provided in his version
  of these images (as seen on invisible.ca).  if you just get a
  black screen you probably have a missing or wrong u-boot.

- you can build your own u-boot from pkgsrc/sysutils/u-boot-pinebook
  which needs to be added to the arm64.img file (be sure to 
  uncompress it! at 8KB from the start of the image:

  # dd if=/usr/pkg/share/u-boot/pinebook/u-boot-sunxi-with-spl.bin of=/dev/rsd0d bs=1k seek=8 conv=sync

  (this is after the image is written to sd, you probably need
  conv=sync,notrync for the fiel.)

  note that you need very recent pkgsrc for this, no earlier than
  november 4th.

- the layout of the image is like this:

  1 - MBR at start of disk
  2 - u-boot at 8KB from start of disk.
  3 - msdos at 16MB from start of disk.
  4 - swap partition (arm64.img has 128MB)
  5 - FFS partition

  only 3 and 5 are described in the MBR, and only 3, 4 and 5 are
  described in the BSD disklabel.

  you can resize some of these.  i have a 100MB msdos partition
  and and 2GB swap partition.

- i got 64GB emmc and installed it.  "fdisk" on this disk showed
  that it was full of 1 bits not 0 bits.  i spent a couple of
  hours failing to get it to be recognised at all (black screen)
  or for the partition table to be seen (boot failure.)  then i
  zeroed the first 1MB of the emmc and tried again.  this worked.
  so something outside of the MBR and the u-boot image itself was
  making the u-boot fail.  i strongly recommend ensuring that
  there are no random bits set in the first parts of your image.

- the serial port shares the audio output.  you can't have both
  at the same time.  there is a little switch near inside the
  case that switches between them.  (this is the new 1080p
  pinebook -- there are 2 older methods as well.)

- i love the ease-of-use of Jared's arm64.img.  it's so easy to
  get a working system from.

  however, when i copied my installation from sd card to emmc,
  i noticed a pair of very odd and in one case, quite bad,
  issues.  after copying the ffs partition to emmc, i noticed
  that the copy was not the same size as the original.  it has
  31 fewer inodes (not too bad -- the total was over 500k).
  however, it has 400MB of less free space:

  Filesystem    1M-blocks       Used      Avail %Cap    iUsed   iAvail %iCap Mounted on
  /dev/ld2a         55947       3624      49526   6%   106552  7091910    1% /
  /dev/ld0a         29728       4033      24208  14%   106516  3812330    2% /mnt

  (these numbers are not 100% the same as the original copy,
  as the root above has been used a bit, but you can see it's
  got much less used space.)


Home | Main Index | Thread Index | Old Index