Port-arm archive

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index][Old Index]

NetBSD on Pogoplug Series 4


I'm trying to get NetBSD running on a Pogoplug Series 4. From what I've read, the hardware is supposed to be similar to Sheevaplug and Dockstar hardware, so I started with a Sheevaplug configuration file.

Using the ArchLinux u-boot, I can boot the kernel off of a FAT partition on a SATA drive (I haven't figured out yet why this u-boot always reports zero USB devices found), but I get gibberish after the kernel starts. Mind you, it's not random gibberish - I get the same gibberish every boot.

I tried changing to every baud rate available and none matches, although the console responds with odd characters suggesting it's waiting at a prompt (asking for root fs, perhaps). I also tried setting CONSPEED to 115200, but got the same.

Any suggestions on how to proceed?


ALARM>> fatload ide 0:1 0x2000000 netbsd.ub
reading netbsd.ub

4709568 bytes read
ALARM>> bootm 0x2000000
## Booting image at 02000000 ...
   Image Name:   NetBSD/sheevaplug 6.99.27
   Created:      2013-11-22  19:32:06 UTC
   Image Type:   ARM NetBSD Kernel Image (uncompressed)
   Data Size:    4709504 Bytes =  4.5 MB
   Load Address: 00008000
   Entry Point:  00008000
   Verifying Checksum ... OK
## Transferring control to NetBSD stage-2 loader (at address 00008000) ...
?V.;????Q./X??i??^??)? ?a?9IX????9???A???V.^??a6?iyaF a)?W?^^??9 ?IP??y?I9A???X?@





??&?q?f?q?q??q?6?P?`@F W.?)9)q????.?A)V?W???I????.? aI1y?qI q???a&I9A??&)?)??)!q?P?A??)??kb@3?Q^v??}?V?`G?(^?@??/f?v?V?)+?&6?PP???Aq?W???q?I q?OQ?^?_??)q?y??X?Y+? ?iy6y^X?_+? ?iy6?W?)y??A??y? a?W????r?P

Home | Main Index | Thread Index | Old Index