Port-arm archive

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index][Old Index]

Re: What partition format works for NSLU2?

Hi John,

On Thu, Jun 20, 2013 at 01:49:02AM +0000, John Klos wrote:
> I've been trying to get NetBSD onto an NSLU2, but no matter what I
> try, I can't get the netbooted NetBSD kernel to see a partition on a
> USB drive:
> sd0 at scsibus0 target 0 lun 0: <, Patriot Memory, PMAP> disk removable
> sd0: 7385 MB, 1853 cyl, 255 head, 32 sec, 512 bytes/sect x 15124992 sectors
> cprng sysctl: WARNING insufficient entropy at creation.
> boot device: <unknown>
> root on sd0a dumps on sd0b
> vfs_mountroot: can't open root device
> cannot mount root, error = 6
> I tried using disklabel and newfs'ing with -B be, then tried using
> fdisk to make a PC-DOS-type partition table, then disklabel, but the
> kernel can't find anything.

Sorry for my late response. I think its not so much as to what partitions the
kernel kan find or not. The sd0 is found and thats a good start :) Have you
made sure that the needed filesystem is compiled in the kernel? I see that FFS
is standard build in in the NSLU2 kernel.

If you want an install kernel look at RPI_INSTALL; copy it to NSLU2_INSTALL
and change the RPI reference to NSLU2 and there you go!

If anything, this gives you a command promt to run disklabel on sd0 to check
if all went right.

With regards,

Attachment: pgpSuO5EzY08N.pgp
Description: PGP signature

Home | Main Index | Thread Index | Old Index