Port-arm archive

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index][Old Index]

What partition format works for NSLU2?


I've been trying to get NetBSD onto an NSLU2, but no matter what I try, I can't get the netbooted NetBSD kernel to see a partition on a USB drive:

sd0 at scsibus0 target 0 lun 0: <, Patriot Memory, PMAP> disk removable
sd0: 7385 MB, 1853 cyl, 255 head, 32 sec, 512 bytes/sect x 15124992 sectors
cprng sysctl: WARNING insufficient entropy at creation.
boot device: <unknown>
root on sd0a dumps on sd0b
vfs_mountroot: can't open root device
cannot mount root, error = 6

I tried using disklabel and newfs'ing with -B be, then tried using fdisk to make a PC-DOS-type partition table, then disklabel, but the kernel can't find anything.

Since there are no install kernels, and since I can't mount NFS at boot (not a single packet is sent to the NFS server and I'm too lazy to diagnose that part of it), I thought it'd be easiest to just use another NetBSD machine to set up the filesystem, but nobody ever documented the format that the NSLU2 kernel expects to see.

One of these days I'm going to have to make a chart of each port, what format they expect to see and how installboot works on each...

John Klos

Home | Main Index | Thread Index | Old Index