Port-arm archive

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index][Old Index]

beagle bone. uhub2: device problem, disabling port 2

forgot to add maillist to CC

---------- Forwarded message ----------
From: Aleksey Cheusov <cheusov%tut.by@localhost>
Date: Sun, Mar 24, 2013 at 2:54 AM
Subject: Re: beagle bone. uhub2: device problem, disabling port 2
To: Lloyd Parkes <lloyd%must-have-coffee.gen.nz@localhost>

On Sun, Mar 24, 2013 at 12:49 AM, Lloyd Parkes
<lloyd%must-have-coffee.gen.nz@localhost> wrote:
> On 24/03/2013, at 10:23 AM, Aleksey Cheusov <cheusov%tut.by@localhost> wrote:
>> I've applied the attached patch (Is it ok?).
> It looks fine to me.

Ok, If I see u-boot/boot process some day, I'll commit it.

>> ---> uhub2: illegal enable change, port 2
> I wouldn't worry about this at the moment, it's probably the BeagleBone 
> booting up and
> doing something funny with the SD Card during the boot process.
>> But cu(1) still doesn't work.
>> asrock# cu -115200 -l /dev/dtyU0
>> Connected <hangs up here>
> Put "bone:dv=/dev/dtyU0:br#115200:pa=none:dc:" in /etc/remote on asrock and 
> try running
> "cu bone" or "tip bone". The "dc" setting tells tip/co to turn off and ignore 
> all modem control
> lines. The dc tag shortcuts all the complicated stuff and just gets you at 
> the serial data.

Unfortunately neither cu/tip nor minicom work. I tried adding


to /etc/remote and then "tip bone" -- no luck.
tip(1) says "Connected" as nothing else.
The same for "cu -l /dev/dtyU0 -f -s 115200".

I also tried minicom with the following /usr/pkg/etc/minicom/minirc.dfl

  pu port             /dev/dtyU0
  pu rtscts           No

minicom shows its own messages and nothing else.
    A -    Serial Device      : /dev/dtyU0
    B - Lockfile Location     : /var/lock
    C -   Callin Program      :
    D -  Callout Program      :
    E -    Bps/Par/Bits       : 115200 8N1
    F - Hardware Flow Control : No
    G - Software Flow Control : No

On Linux (SL-6.4) everything works fine both with minicom and cu (plus
"stty -a -F /dev/ttyUSB0").
Several months ago minicom worked fine for me with HP t5335 under
NetBSD on asrock.

Home | Main Index | Thread Index | Old Index