Port-arm archive

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index][Old Index]

Re: Booting NetBSD/evbarm on QEMU (IntegratorCP)


> As part of a personal project to get familiar with the ARM
> architecture, I've been working on getting NetBSD/evbarm to boot on
> QEMU. I've based my work on the present support for ARM Integrator
> evaluation board.

Excellent !

> And a ready to use image here:
> http://blogs.nologin.es/slopez/uploads/netbsd.gz.ub
> It can be used with something like this: "qemu-system-arm -M
> integratorcp -cpu arm1136 -m 128m -kernel netbsd.gz.ub -serial stdio
> -net nic -net tap". This image doesn't contain a ramdisk, so you'll
> need an NFS with NetBSD/evbarm root, and a properly configured DHCP
> server.

I'm trying this kernel and sadly it panics when executing init:

    root on
    root file system type: nfs
    warning: no /dev/console
    init path (default /sbin/init): 
    init: trying /sbin/init
    uvm_fault(0xc13e591c, 20646000, 1) -> e
    Fatal kernel mode data abort: 'Translation Fault (S)'
    trapframe: 0xc76cdd20
    FSR=00000005, FAR=20646598, spsr=20000113
    r0 =20646574, r1 =00000000, r2 =c1036000, r3 =00000000
    r4 =c1036040, r5 =00000004, r6 =00000000, r7 =00000001
    r8 =c1036040, r9 =00000003, r10=c038a33c, r11=c76cddd8
    r12=00000000, ssp=c76cdd70, slr=c02730b0, pc =c02723a0
    Stopped in pid 38.1 (sh) at     netbsd:uvm_pagealloc_pgfl+0x150:        ldr
    2, [r0, #0x024]

I run qemu in a Xen PV domU runing Debian Wheezy. May the crash be due to the
Xen virtualisation layer ?



Home | Main Index | Thread Index | Old Index