Port-arm archive

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index][Old Index]

TS-7200 INSTALL kernels fail

I'm attempting to install NetBSD 5.01 on a TS-7200. It appears that the evbarm kernels up on ftp.netbsd.org/pub/NetBSD/NetBSD-5.0.1/evbarm/installation/instkernel/ fail to boot. I tried both netbsd-TS7200_INSTALL.srec and netbsd-TS7200_INSTALL.bin. For example, from the RedBoot on the TS-7200:
RedBoot> load netbsd-TS7200_INSTALL.srec
Using default protocol (TFTP)
Entry point: 0x00200000, address range: 0x00200000-0x007f8dac
RedBoot> g
RedBoot> load -r -b 0x00200000 netbsd-TS7200_INSTALL.bin
Using default protocol (TFTP)
Raw file loaded 0x00200000-0x00839013, assumed entry at 0x00200000
RedBoot> g
In both cases, after 'go', the TS-7200 is toast. I also built the TS7200_INSTALL kernel config (5.0_STABLE branch) and had the same result.
I was able to boot the regular kernel. From ftp.netbsd.org/pub/NetBSD/NetBSD-5.0.1/evbarm/binary/kernel/:
RedBoot> load -r -b 0x00200000 netbsd-wd0.bin-TS7200  
Using default protocol (TFTP)
Raw file loaded 0x00200000-0x005383ab, assumed entry at 0x00200000
RedBoot> g
Copyright (c) 1996, 1997, 1998, 1999, 2000, 2001, 2002, 2003, 2004, 2005,
    2006, 2007, 2008, 2009
    The NetBSD Foundation, Inc.  All rights reserved.
Copyright (c) 1982, 1986, 1989, 1991, 1993
    The Regents of the University of California.  All rights reserved.
NetBSD 5.0.1 (TS7200) #0: Thu Jul 30 02:38:04 UTC 2009
Can someone give me pointers to investigate how you can boot the NetBSD 5.01 INSTALL kernel?
Thanks - Joel

Home | Main Index | Thread Index | Old Index