Port-arm archive

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index][Old Index]

Re: Clock error on bootup - NSLU2

Steve Woodford wrote:
Correct. The RTC is only used to set the kernel's clock at startup, and is sync'd whenever the date/time is changed.
Slightly more information.  On boot up, I get the aforementioned error:

xrtc0: xrtc_clock_read: failed to read rtc at 0x0
xrtc0: xrtc_clock_read: failed to read rtc at 0x0
WARNING: preposterous TOD clock time
WARNING: using filesystem time

When I set the date, using either ntpdate or date, I get the following error:

xrtc0: xrtc_clock_write: failed to write-unlock status register(WEL=1)
Cannot set TOD clock time

I erroneously reported that that ntpdate worked correctly. It actually failed the first time with the above error. Subsequent instances of ntpdate appeared to work, but the RTC wasn't accessed since the time had not changed sufficiently. If you set an incorrect time/date using date, you will see the same error message. The next time you run ntpdate, you'll see the same error again, and so on.

Does anybody know of a way to check the hardware? I'm perfectly willing to concede that I'm having a hardware problem, but rtos reported the same error. While we could both be having hardware problems, it seems less likely. Could this have anything to do with the timing for the I2C bit-banging? Just wondering if the clock speedup had any effect on that.


Home | Main Index | Thread Index | Old Index