Port-amiga archive

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index][Old Index]

Re: Installation probs 6.1.1 and 6.99 (maybe G-Rex related?)


Am 01.09.2013 um 22:07 schrieb Radoslaw Kujawa:

> Hi.
> On 1 Sep 2013, at 6:33 PM, Alexander Coers <alexander.coers%gmx.de@localhost> 
> wrote:
>> Since I acquired a G-Rex for my A4000D and my A1200 is curently out of 
>> order, I thought I
>> install NetBSD on my BigBox (CSPPC 060 50MHz, 128MB Ram).
>> But release 6.1.1 fails during boot directly after loading the kernel.
> We know about this problem, fixed it in HEAD branch already, and the fix will 
> be pulled into 6.1.2 and 6.2.
>> Either it prints it could not load kernel symbols or (if started without -S) 
>> it bails directly into debugger 
>> with different errors (have to try it again for correct description, since I 
>> always use -Sn2).
> I guess the error was "panic: uvm_km_suballoc: unable to allocate space in 
> parent map" ? That's typical message for problem mentioned above.

Yes, exactly.

>> Then I tried miniroot.fs from 
>> http://nyftp.netbsd.org/pub/NetBSD-daily/HEAD/201308311340Z/amiga/
>> The 6.99 boots without problems, then detects G-Rex PCI busboard and prints:
>> ar0 at zbus0 pa 0xfffe0000 man/pro 8512/102 PCI bridge 4kb
>> ar1 at zbus0 pa 0xfffa0000 man/pro 8512/102 PCI I/O area 64kb
>> ar2 at zbus0 pa 0xfffc0000 man/pro 8512/102 PCI config area 128kb
>> ar3 at zbus0 pa 0x80000000 man/pro 8512/102 PCI memory BAR 262144kb
>> ar4 at zbus0 pa 0x90000000 man/pro 8512/102 PCI memory BAR 139264kb
>> ar5 at zbus0 pa 0xa0800000 man/pro 8512/102 PCI memory BAR 139264kb
>> ar6 at zbus0 pa 0xb1000000 man/pro 8512/102 PCI memory BAR 131200kb
>> ar7 at zbus0 pa 0xba000000 man/pro 8512/102 PCI memory BAR 32768kb
> These lines should be something like:
> p5membar0 at zbus0
> Seems like first few pixels are missing?
> Besides, these BARs are _huge_ for an Amiga. This certainly looks fishy.
>> 983040 kb PCI memory space (0x80000000 to 0xbc000000)
>> allocating too much Zorro I/O address space
> This does not look right for a configuration you have described. Which 
> version of G-REX firmware do you have? If possible I'd like to see more of 
> that dmesg.
I have applied the latest G-Rex firmware 44.71 with OpenPCI support.
And yes, some pixels were missing. Readjusted the TFT and now everything looks 
How can I save the dmesg from inside the debugger? Then I can provide you the 

>> And I am back in debugger.
>> At the moment I have a Voodoo 4, a (probably defect) Permedia2 Gfx Board and 
>> a RTL8029 nic installed in the G-Rex.
> First please try to remove the broken Permedia card and report back.
>> On Zorro side only a Deneb is installed.
> Any Deneb related problems should be fixed in HEAD and 6.1.1.
>> My next step would be to remove the Permedia2 and if it still fails the 
>> Voodoo4 as well.
>> Any further tips to get NetBSD running here?
> As, suggested above, try to remove that Permedia and report back. 
> Also, can I get a dump from AmigaOS PCI report tool? There surely is one for 
> G-REX (don't remember its name now). With and without said Permedia board.

Okay, here the output of the newpciscan tool with all 3 PCI cards inserted:

cybpci.library 2.2
BoardObject 0x8013F54
Bus 0 <CyberstormPPC GRex PCI> Slot 1 Function 0
 Vendor 0x104C <Texas Instruments> Device 0x3507 <>
  Class 0x3 <Display Controller>
  SubClass 0x0 <PC Compatible>
  ProgInterface 0x0 <VGA>
  Command 0x0
  Base 0: Address 0xB1000000 Size 0x8020000
  Base 1: Address 0x90000000 Size 0x8800000
  Base 2: Address 0xA0800000 Size 0x8800000
BoardObject 0x8014564
Bus 0 <CyberstormPPC GRex PCI> Slot 2 Function 0
 Vendor 0x10EC <Realtek Semiconductor> Device 0x8029 <RTL8029>
  -> NE2000 compatible Ethernet
  Class 0x2 <Network Controller>
  SubClass 0x0 <Ethernet>
  ProgInterface 0x0 <>
  Command 0x0
  Base 0: Address 0x7FA1000 Size 0x8000020
BoardObject 0x8014B4C
Bus 0 <CyberstormPPC GRex PCI> Slot 3 Function 0
 Vendor 0x121A <3dfx Interactive Inc> Device 0x7 <>
  Class 0x3 <Display Controller>
  SubClass 0x0 <PC Compatible>
  ProgInterface 0x0 <VGA>
  Command 0x0
  Base 0: Address 0xBA000000 Size 0x2000000
  Base 1: Address 0x80000000 Size 0x10000000
  Base 2: Address 0xFFA1800 Size 0x800

However I made further progress:
- removing the Permedia2 results in a trap after the ne2 driver prints it init 
- removing the Realtek (leaving only the Voodoo 4) results in a clean boot and 
install is possible.


Home | Main Index | Thread Index | Old Index