Port-amiga archive

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index][Old Index]

NetBSD 6.1 bootblock install problems

I tried the latest 6.1 ISO for amiga, and encountered various problems :
After running successfully the miniroot install (minor glitches : skipped the 
ALGOR EPROM in order to work, had to DL a 5.0 miniroot image , not the one 
supplied with the ISO) , I installed the whole distro to the root partition ( 2 
partitions set according to the documentation, root & swap).
It failed to install the bootblock, with a core dump of installboot (Bad system 
call -core dumped- installboot.core). The whole system is present in the root 
(wd0a) partition, checked the contents after mounting the BFFS from WB3.9.

The problems so far : binaries & utilities that are obsolete or no good ( 
miniroot won`t boot , NETBSD_61:amiga/installation/misc /loadbsd#? won`t work 
with elf binaries. I had to DL 
http://ftp.nl.freebsd.org/pub/ftp/NetBSD/arch/amiga/utils/loadbsd-3.gz , not 
included in the distro ).
loadbsd stops with the gray screen , no disk activity ( flags -I ff -b worked 
fine with miniroot, won`t work here instead).
Loading miniroot, and ctrl^C at KB selection gets me to shell (wd0b as root, 
dump none, rest default). I enter the following: 
mount /dev/wd0a /mnt
/mnt/rescue/installboot -v  /dev/wd0a /mnt/usr/mdec/dootxx_ffs
installboot: Opening file system `/dev/wd0a` read-write: Device busy
The reverse syntax  ( /mnt/rescue/installboot -v  /mnt/usr/mdec/dootxx_ffs  
/dev/wd0a )  gives Bad system call

Tried the runbootblock utility, no luck:
runbootblock -dscsi.device -u0 -proot
root partition found @ block 6111000
Invalid bootblock

My config: A4000D, CSPPC/060, 16+128MB fast ram, CV3D & scandoubler, X-Surf, 
The only change from previous working configuration (many years ago v1.4/1.6) 
is an IDE2CF  adapter on the mobo IDE controller (I`ve already successfully 
installed WB3.9 & OS4.1).

Thank you in advance,
Costantino Damilakis                                      

Home | Main Index | Thread Index | Old Index