Port-amiga archive

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index][Old Index]

Re: problems when building mysql in NetBSD 6

Al wrote:

> I can't build mysql51-client on NetBSD 6.

Sorry for not replying earlier, but it is not easy to find the time to
reproduce such an error on my Amiga. The machine is busy for at least 6
hours to build the client (fortunately I already got Perl).

> This is the error that I get:
> checking libedit variant of rl_completion_entry_function... no
> checking defined rl_compentry_func_t and rl_completion_func_t... no
> checking HIST_ENTRY is declared in readline/readline.h...
> configure: error: Could not find system readline or libedit libraries
>                Use --with-readline or --with-libedit to use the bundled
>                versions of libedit or readline
> *** Error code 1

That's the same error which you got with mysql5-client. So you have a
general problem with readline or libedit.

I have built mysql5-client over the last night without any problem! Using
pkgsrc-2012Q3 on a 6.0 installation.

> Is readline missing from my system or is it just not finding it?

Maybe you need to fix your 6.0 installation. Either there is something wrong
with it, or the mysql-client package has a bug and depends on other
packages already installed, but not actually entered in its depedencies.

For example I had also the readline-6.2 package installed. Maybe this makes 
a difference?

> If it is just not finding readline, how do I tell it where it is?

It should find it. When I look into my successful config.log, I see the
following lines:

configure:25833: checking defined rl_compentry_func_t and
configure:25855: c++ -c  -DDBUG_OFF -Os -DUSE_OLD_FUNCTIONS -I/usr/include  
-fno-implicit-templates -fno-exceptions -fno-rtti -Dunix -Dunix
-I/usr/include conftest.cpp >&5
conftest.cpp: In function 'int main()':
conftest.cpp:310:3: error: 'rl_completion_func_t' was not declared in this
conftest.cpp:310:25: error: 'func1' was not declared in this scope
conftest.cpp:310:54: error: expected primary-expression before ')' token
conftest.cpp:310:55: error: expected ';' before numeric constant
configure:25855: $? = 1
configure: failed program was:
configure:25871: result: no
configure:25875: checking HIST_ENTRY is declared in readline/readline.h
configure:25896: c++ -c  -DDBUG_OFF -Os -DUSE_OLD_FUNCTIONS -I/usr/include  
-fno-implicit-templates -fno-exceptions -fno-rtti -Dunix -Dunix
-I/usr/include conftest.cpp >&5
configure:25896: $? = 0
configure:25912: result: yes

So the failure with rl_completion_func_t is normal.

But then it finds HIST_ENTRY in readline/readline.h and continues. After
that your configuration breaks with an error.

Can you check /usr/include/readline/readline.h for HIST_ENTRY? Maybe it is

> I have tried editing Makefile.common. I changed --without-readline to 
> --with-readline. I now get this error:
> [...]
> g++: error trying to exec '/usr/libexec/cc1plus': execv: Cannot
> allocate memory

Uh... out of memory. How much do you have installed? I have 128MB physical
memory and 512MB swap. I was compiling on an A3000 with CSPPC/060.

> Has anyone else tried to build mysql and are they having the same 
> problems? I really need this system to work. I just can't afford any
> more downtime.

I have uploaded my mysql5-client package to:

Its installation depends on Perl>=5.0. Hope you already got that.

Frank Wille

Home | Main Index | Thread Index | Old Index