Port-amd64 archive

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index][Old Index]

Re: unable to boot amd64-uefi-install from USB stick on a MacBook2,1

At Wed, 11 Dec 2019 17:25:17 -0800, "Greg A. Woods" <woods%planix.ca@localhost> wrote:
Subject: unable to boot amd64-uefi-install from USB stick on a MacBook2,1
> However no matter which option I selected, including a "boot netbsd -vs"
> from the boot prompt, would do anything more than load the kernel (I see
> the various section size numbers, with a nearly invisible spinner), then
> it clears the screen, then hangs solid -- just the little un-blinking
> cursor in the "top middle" of the screen and the keyboard goes
> unresponsive and a full multi-second press on the power switch is
> necessary to shut it off.

So, I've since tried a number of different builds of amd64-uefi images,
from 8.0, my own builds, and several release candidates and daily
builds, none with any luck.

I did manage to boot a daily build on a MacBook Pro I was using over the
weekend, and it worked A-OK.

However in searching related things I just came across a reminder about
memory issues on this particular model of MacBook2,1.  It originally
shipped with 2x1GB memory modules.  At some point I upgraded it to 2x2GB
modules.  Under MacOS it only uses 3GB for some reason (though the
hardware info clearly shows 4GB installed).

Is it possible there's a quirky physical memory map on this machine that
NetBSD might be having problems with?

					Greg A. Woods <gwoods%acm.org@localhost>

Kelowna, BC     +1 250 762-7675           RoboHack <woods%robohack.ca@localhost>
Planix, Inc. <woods%planix.com@localhost>     Avoncote Farms <woods%avoncote.ca@localhost>

Attachment: pgp30Wf9rRnVb.pgp
Description: OpenPGP Digital Signature

Home | Main Index | Thread Index | Old Index