Port-amd64 archive

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index][Old Index]

Re: Linux emulation problem

In article 
Torsten Harenberg  <harenberg%physik.uni-wuppertal.de@localhost> wrote:
>Dear list,
>sorry, this is not that much port-amd64 related, but as I had several
>experienced answers here already, I would like to ask those of you with
>linux emulation experience to have a short look into this:
>As already described before, I try to run a linux binary (EMC^2
>Networker client) on a NetBSD/amd64 machine running under Xen.
>As I have learned before, I have upgraded this machine now to CURRENT
>(both kernel and world):
>NetBSD mail.physik.uni-wuppertal.de 5.99.53 NetBSD 5.99.53 (XEN3_DOMU)
>#0: Mon Jun 20 09:41:08 CEST 2011 
>So Linux emulation runs now in principle. 
>However, I still have trouble to run the (unfortunately closed source)
>daemon provided by EMC^2, which ends in a core dump.
>I run it with ktrace and I think the critical part is here
> 14571  14571 nsrexecd CALL  bind(3,0x7f7fffff7d60,0xc)
> 14571  14571 nsrexecd MISC  linux sockaddr: 12, 100000000000000000000000
> 14571  14571 nsrexecd MISC  new sockaddr: 12, 0c2200000000000000000000
> 14571  14571 nsrexecd RET   bind -1 errno -95 Operation not supported
>Although I'm not sure, why this should crash the application.
>I have tried both suse100 and suse113 emulation layers, the behavior is
>this same.
>Full kdumps are here:
>Maybe one of you has a clue...

Great, now that you are on current it is a lot easier to help. Please
compile a kernel with DEBUG_LINUX. This will dump the contents of the
sockaddr we are barfing on. I think 0xc (12) is a tad small so I am
wondering what we are trying to do here.


Home | Main Index | Thread Index | Old Index