Port-amd64 archive

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index][Old Index]

Linux emulation problem

Dear list,

sorry, this is not that much port-amd64 related, but as I had several 
experienced answers here already, I would like to ask those of you with linux 
emulation experience to have a short look into this:

As already described before, I try to run a linux binary (EMC^2 Networker 
client) on a NetBSD/amd64 machine running under Xen.

As I have learned before, I have upgraded this machine now to CURRENT (both 
kernel and world):

NetBSD mail.physik.uni-wuppertal.de 5.99.53 NetBSD 5.99.53 (XEN3_DOMU) #0: Mon 
Jun 20 09:41:08 CEST 2011  

So Linux emulation runs now in principle. 

However, I still have trouble to run the (unfortunately closed source) daemon 
provided by EMC^2, which ends in a core dump.

I run it with ktrace and I think the critical part is here

 14571  14571 nsrexecd CALL  bind(3,0x7f7fffff7d60,0xc)
 14571  14571 nsrexecd MISC  linux sockaddr: 12, 100000000000000000000000
 14571  14571 nsrexecd MISC  new sockaddr: 12, 0c2200000000000000000000
 14571  14571 nsrexecd RET   bind -1 errno -95 Operation not supported

Although I'm not sure, why this should crash the application.

I have tried both suse100 and suse113 emulation layers, the behavior is this 

Full kdumps are here:


Maybe one of you has a clue...

Thanks for the help 


<>                                                              <>
<> Dr. Torsten Harenberg     harenberg%physik.uni-wuppertal.de@localhost  <>
<> Bergische Universitaet                                       <>
<> FB C - Physik             Tel.: +49 (0)202 439-3521          <>
<> Gaussstr. 20              Fax : +49 (0)202 439-2811          <>
<> 42097 Wuppertal                                              <>
<>                                                              <>
<><><><><><><>< Of course it runs NetBSD http://www.netbsd.org ><> 

Home | Main Index | Thread Index | Old Index