Port-amd64 archive

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index][Old Index]

Re: openldap and bdb

i sent the following mail not to the whole list. sorry about that mistake. for completion and maybe some help with my ldapi, i send it again.

Geert Hendrickx schrieb:
On Thu, Sep 11, 2008 at 03:48:19PM +0200, neys wrote:
- ldapsearch over ldapi:/// does not work at all ldapi is not accessible.
ldapsearch says: ldap_sasl_bind(SIMPLE): Can't contact LDAP server (-1)

Can you try ldapsearch with -x for simple authentication instead of SASL?

it was an simple bind, i guess '(SIMPLE)' indicates that, but i do not
know how it looks like on a sasl bind. it do not use that.

- ldapsearch over ldap://localhost/ does work, i get the whole database
as output. slapd does not crash. but a ldapsearch with filter (e.g.
objectClass=account) causes an slapd core dump.  ldapsearch says:
ldap_result: Can't contact LDAP server (-1)

Have you tried increasing the stacksize ulimit as suggested by MESSAGE.NetBSD?
Type "ulimit -s", double the value you get, eg. "ulimit -s 4096", and then
restart slapd.

i thought i had already done this, but i checked it out again and it was
not... i manually set it and look, i can search with filters. thank you
very mutch for that hint. where exactly is this mentioned? i could not
find MESSAGE.NetBSD in pkgsrc/databases/openldap-server.

but, what is the best way to set the stacksize? i tried /etc/login.conf,
but ist does not like "stacksize-cur" (setting resource limit stacksize:
Invalid argument). no luck with sysctl. for now i created


ulimit -s 4096

there is still the problem with my ldapi. any other suggestions there?

thanks in advance,


Home | Main Index | Thread Index | Old Index