Port-amd64 archive

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index][Old Index]

success with real video on amd64

I had success with real video on amd64 using mplayer.

Build mplayer with --enable-real
(Edit /usr/pkgsrc/multimedia/mplayer-share/options.mk to allow that.)
Even if codecs directory exists, if real is disabled it won't try.

And you can choose custom directory for your realplayer codecs  
--realcodecsdir. I think it defaults  to /usr/pkg/lib/codecs/
(unless configure argument in options.mk is enabled somehow).

For "realvid" tried, mplayer tries drvc.so, drvc.dll, drv4.so.6.0, 
drv43260.dll, drvc (MacOS)

And mplayer tries for "realaud": sipr.so.6.0, sipr.so, sipr.dll, 
sipr3260.dll, sipr (MacOS)

Using pkgsrc packages: mplayer-share-1.0rc10 and mplayer-1.0rc10nb4 (and 
not realplayer-codecs-8.20050115nb1 which is 32-bit and does not work.) My 
success was on NetBSD/amd64 4.99.55.

The two different sets of 64-bit codecs for real player I tried follow. 
The first one was successful. The second one was not successful.

1) essential-amd64-20071007.tar.bz2 available from 
http://www4.mplayerhq.hu/MPlayer/releases/codecs/ and mirrors.

It provides cook.so, drvc.so, sipr.so.

I made directory and copied to them to /usr/pkg/lib/codecs

The codec files are all:

ELF 64-bit LSB shared object, x86-64, version 1 (SYSV), not strippe

They all use:

        -lstdc++.6 => /usr/lib/libstdc++.so.6
        -lm.6 => not found
        -lgcc_s.1 => /usr/lib/libgcc_s.so.1
        -lc.6 => not found

So I created symlinks:

 cd /usr/lib
 sudo ln -s libm.so.0 libm.so.6
 sudo ln -s libc.so libc.so.6

mplayer was successful. I watched and listed to video.

Selected video codec: [rv3040] vfm: realvid (Linux RealPlayer 10 RV30/40 


AUDIO: 16000 Hz, 1 ch, s16le, 16.0 kbit/6.25% (ratio: 2000->32000)
Selected audio codec: [ra10sipr] afm: realaud (RealPlayer 10 RealAudio 

I made directory and copied to them to /usr/pkg/lib/codecs

2) Used codecs from realplay- 
tarball from helix project. This was a testing release.

I created a subdirectory to extract source into. Then copied the so 
libraries from codecs subdirectory to /usr/pkg/lib/codecs/.

In addition to libm symlink above, I did:

 sudo ln -s libstdc++.so libstdc++.so.5
 sudo ln -s libc.so libc.so.6

This was not successful. Probably due to libstdc++ and maybe libc 

I removed the libstdc++.so.5 symlink and reverted back to 
essential-amd64-20071007 codecs and all was well.

TODO: always build mplayer package with realplayer enabled.

TODO: package the essential-amd64 package for this.

  Jeremy C. Reed

p.s. Note that some "rm" files use ffcook from ffmpeg and not realaud.
Mplayer will tell you what codecs it uses.

Home | Main Index | Thread Index | Old Index