Port-alpha archive

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index][Old Index]

Re: Alpha boot magic questions

Can VMS or Tru64 boot off the drive? I suspect that would answer the "is it the scsi converter, or is it the BSD bootloader that is committing the crimes question.


 Al Boyanich
 adb -w -P "world> " -k /dev/meta/galaxy/ksyms /dev/god/brain

On Thu, 25 Mar 2010, John Klos wrote:


After updating my firmware, I still can't get my Alpha to boot from the hard disk. I tried doing a complete install from a 5.0.2 CD and tried running installboot manually:

# installboot -v /dev/rsd0c bootxx_ffs
File system:         /dev/rsd0c
Primary bootstrap:   bootxx_ffs
Bootstrap start sector:  1
Bootstrap sector count:  13
New boot block checksum: 0xa3dbcfeefd5d168e
Writing bootstrap
Writing boot block

Why does partition "a" start at sector 0 if the bootstrap code takes 13 sectors? Just curious.

No matter what I try, I always get:

failed to open dka0.

If I try to use the bootloader on the CD to boot the kernel off the SCSI disk, I get:

Boot file: dka0:netbsd
Boot flags: a
open dka0:netbsd: No such file or directory

Boot failed!  Halting...

Maybe dka0:netbsd isn't the correct syntax.

The drive looks like this from the 5.0.2 boot CD's dmesg:

sd0 at scsibus0 target 0 lun 0: <ST316002, 3A, 8.01> disk fixed
sd0: 149 GB, 77525 cyl, 64 head, 63 sec, 512 bytes/sect x 312581808 sectors
sd0: sync (100.00ns offset 8), 8-bit (10.000MB/s) transfers, tagged queueing

It makes me wonder if the SRM simply can't talk to the drive. It's a 160 gig IDE drive with an Acard SCSI-IDE (7720U) adapter. I use these kinds of adapters everywhere, including Amigas, m68k Macs, and even VAXen.

The exact same adapter with a slightly larger drive is in one of my VAXstation 4000/60, and it's never had any booting issues:

sd0 at scsibus0 target 0 lun 0: <Maxtor 6, B200P0, BAH4> disk fixed
sd0: 189 GB, 98784 cyl, 64 head, 63 sec, 512 bytes/sect x 398297088 sectors
sd0: sync (160.00ns offset 15), 8-bit (6.250MB/s) transfers, tagged queueing

I even tried a different SCSI-IDE adapter, but no go. I suppose my next test will be to see if a real SCSI drive works...

Any other suggestions?


Home | Main Index | Thread Index | Old Index