Mayuresh <mayuresh%acm.org@localhost> writes: > In file included from coders/pdf.c:90:0: > ./coders/ghostscript-private.h: In function 'InvokeGhostscriptDelegate': > ./coders/ghostscript-private.h:136:5: error: 'gsapi_set_arg_encoding' > undeclared (first use in this function); did you mean 'gsapi_set_stdio'? > gsapi_set_arg_encoding; > ^~~~~~~~~~~~~~~~~~~~~~ > gsapi_set_stdio > > > Any relation with this  thread which says ghostscipt needs to be > upgraded to version 9.19 to 9.21 > >  https://github.com/NickNaso/ghostscript4js/issues/25 When asking question, please try to provide the data that anyone would need to answer your question. In general: What OS and version? What version of pkgsrc, and is everything up-to-date relative to that version? Do you have *any* non-default config in mk.conf? and in this case: What version of ghostscipt do you have installed? -gpl or -agpl? Version number? Since ghostscipt-gpl is unmaintained, obviously you should be using ghostscipt-agpl. And pkgsrc is at 9.55.0. So the idea that upgrading from 9.19 to 9.21 when you are at 9.55.0 doesn't make a lot of sense. Please explain your thinking more. The error was that gsapi_set_encoding is undefined. As an ACM member you should be able to look for that in the ghostscript sources and headers ;-) What did you find?
Description: PGP signature