pkgsrc-Users archive

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index][Old Index]

Re: cad/qcad only prints to PDF, no other options

On Fri, 5 Jun 2020, Iain Hibbert wrote:

> > I don't use QCad often so I was surprised today to discover that the 
> > only printing option available is to print to PDF.

That is, it used to print to the printer just fine, but I think this is
the first time I used it since the switch to qt5 (or at least tried to
print anything).

> I've never tried to print as I only have a printer.


Are you perhaps thinking the only direct hardcopy ouput device would
be a pen plotter of some kind?  It would be neat to have one, but they
are rare and expensive--even more so today.

So, a laser printer works just fine.  (Mine is even a Real Printer^{tm}
which lives on ethernet, speaks PostScript, and can duplex-print.  It
also speaks PCL and ASCII as necessary.)

> (I always use export to PDF which works for me :)

Yes, I'm sure that works, but it would be nice to avoid the extra step
to get hard-copy output.

> as far as I can tell it uses the Qt framework though, and QtPrintsupport 
> is part of x11/qt5-qtbase so should be included. However, it is normally 
> distributed as a 'bundle' with everything copied in to private directories 
> but I have broken that part up a bit and tried to make it use the 
> installed versions in /usr/pkg/qt5/plugins. I could have broken it or 
> never discovered it was missing. Do you have a 
> printformats/ under there? (I don't have one)

There is no "/usr/pkg/qt5/plugins/printformats" subdirectory at all let
alone a "" file under it.

> I think you would have to specifically enable PKG_OPTIONS.qt5+=cups don't 
> know if there is any other printing support available in Qt5

Yes, x11/qt5-qtbase/ has "cups" as a "supported" option, but not
a "suggested" (i.e. default enabled) option.

If qt5 has declared CUPS the only way to print, I consider it broken.

|/"\ John D. Baker, KN5UKS               NetBSD     Darwin/MacOS X
|\ / jdbaker[snail]consolidated[flyspeck]net  OpenBSD            FreeBSD
| X  No HTML/proprietary data in email.   BSD just sits there and works!
|/ \ GPGkeyID:  D703 4A7E 479F 63F8 D3F4  BD99 9572 8F23 E4AD 1645

Home | Main Index | Thread Index | Old Index