pkgsrc-Users archive

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index][Old Index]

Re: xscreensaver PLIST errors

На 2020-01-18 в 22:07, David H. Gutteridge написа:
> On Sun, 12 Jan 2020 at 09:03:28 +0530, Mayuresh wrote:
>> Vaguely recollect, this is possibly an old issue.
>> ERROR: ************************************************************
>> ERROR: The following files are in the PLIST but not in
>> /usr/pkgsrc/x11/xscreensaver/work/.destdir/usr/pkg:
>> /usr/pkgsrc/x11/xscreensaver/work/.destdir/usr/pkg/bin/xscreensaver-
>> gl-helper
>> /usr/pkgsrc/x11/xscreensaver/work/.destdir/usr/pkg/libexec/xscreensave
>> r/antinspect
>> <snip> ... total 346 lines
>> I have in mk.conf:
>> PKG_OPTIONS.xscreensaver += -opengl
>> My option list is blank.
>> These options are currently enabled:
>> This is on pkgsrc-current after a recent update on amd64 on NetBSD 8.0
>> PS: I worked around by re-generating PLIST to get going.
> Hi,
> I've adjusted this package's PLIST and PLIST.opengl accordingly. If you
> should need to build it again, it should now work for you with opengl
> disabled.

That's fine now; I usually build it with GL enabled. The individual
programs in /usr/pkg/libexec work just fine when invoked on the command
line or in the small preview of xscreensaver-demo, but if I run them
full-screen, I get either a message from Mesa that the device could not
be recognized, or a black screen with the mouse cursor (working) and
nothing else - I even can't switch to another console with Ctrl-ALT-Fx
and had to ssh into the machine to reboot - killing all running programs
related to it did not solve it (the program itself, xdcreensaver[-demo],
X, gdm - the screen stays the same).

This is on 9.99.39 amd64, the laptop has Intel 530 graphics; from dmesg:


nouveau0 at pci1 dev 0 function 0: NVIDIA product 139a (rev. 0xa2)
i915drmkms0 at pci0 dev 2 function 0: Intel HD Graphics 530 (GT2) (rev.
nouveau0: info: NVIDIA GM107 (1171a0a2)
nouveau0: autoconfiguration error: error: bios: unable to locate usable
nouveau0: autoconfiguration error: error: bios ctor failed, -22
nouveau0: autoconfiguration error: unable to create nouveau device: 22
i915drmkms0: interrupting at ioapic0 pin 16 (i915drmkms0)
kern error:
*ERROR* kern error:
*ERROR* Failed to fetch GuC firmware from i915/skl_guc_ver4.bin (error -2)
failed to load firmware i915/skl_dmc_ver1.bin (0)
kern error:
*ERROR* The driver is built-in, so to load the firmware you need to
kern error:
*ERROR* Failed to initialize GuC, error -5 (ignored)
intelfb0 at i915drmkms0
intelfb0: framebuffer at 0xffff96014dac0000, size 1920x1080, depth 32,
stride 7680
wsdisplay0 at intelfb0 kbdmux 1: console (default, vt100 emulation),
using wskbd0



> Regards,
> Dave

Home | Main Index | Thread Index | Old Index