pkgsrc-Users archive

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index][Old Index]

conflicting dependencies in sysutils/flashrom

Just added sysutils/flashrom to my build list for APU2 bios updates but ran into a dependency conflict:

# make print-build-depends-list
This package requires package(s) "autoconf-2.69nb9 automake-1.16.1nb1 boost-headers-1.71.0nb2 boost-jam-1.71.0nb1 boost-libs-1.71.0 bsdtar-3.4.0 cmake-3.16.1 confuse-3.2.2 curl-7.67.0 cwrappers-20180325 digest-20190127 dmidecode-3.2nb5 gettext-lib-0.20.1 gettext-m4-0.20.1nb1 gettext-tools-0.20.1 gmake-4.2.1nb1 gsed-4.7 help2man-1.47.11 icu-64.2nb1 libffi-3.2.1nb4 libftdi1-1.1nb15 libidn2-2.3.0 libtool-base-2.4.6nb2 libunistring-0.9.10 libusb-compat-0.1.7 libusb1-1.0.22nb1 libuuid-2.32.1 libuv-1.34.0 libxml2-2.9.10 m4-1.4.18nb2 mozilla-rootcerts-1.0.20191207 nghttp2-1.40.0 p5-gettext-1.07nb4 pciutils-3.6.2nb1 perl-5.30.1 pkgconf-1.6.0 python27-2.7.17 python37-3.7.5 readline-8.0 rhash-1.3.9 swig-1.3.38nb1 xmlcatmgr-2.2nb1" to build.

Problem is that when you actually try and build it you get:

=> Creating binary package /pkg_comp/packages/All/libusb-compat-0.1.7.tgz
===> Installing binary package of libusb-compat-0.1.7
pkg_add: Package `libusb-compat-0.1.7' conflicts with `libusb-[0-9]*', and `libusb-0.1.12nb7' is installed. pkg_add: Installed package `libusb-0.1.12nb7' conflicts with `libusb-compat-[0-9]*' when trying to install `libusb-compat-0.1.7'.
pkg_add: 1 package addition failed
*** Error code 1

I this this tangle is coming from devel/libftdi1 but I'm not sure how to untangle it.


Home | Main Index | Thread Index | Old Index