pkgsrc-Users archive

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index][Old Index]

weird fontconfig / freetype issie solved by removing old native libraries

hi folks.

i was updating a netbsd-8 system's packages this week and i had some
oddness with fontconfig that i tracked down to it buildlinking both
native and xsrc parts, mostly the native pkgconfig file.

then i realised i had a couple of dozen packages affected by this.

i don't understand exactly why this fixed it, but i'm assuing that
there is some interaction between pkgconfig, shlibs visible in
x11-links and native xsrc integration.

since packages are wanting the newer version of fontconfig, and
netbsd-8's freetype is also dated, i set
PREFER.{fontconfig,freetype2}=pkgsrc in mk.conf to ensure that they
are used by default.

the main problem was having netbsd-5 era* (and,
similarly, freetype2 ones) in /usr/X11R7/lib, and those ending up
in the x11-links package.  once i removed those old libraries from
my /usr/X11R7/lib, and rebuilt x11-links, i was able to rebuild all
affected packages (in the right order!) to get rid of the double

i wanted to share this information incase others have the same
problem when building new packages.  besides another minor build
issue i already commited a fix for, this was the only problem i had
with the almost 1000 packages i install (actually, libreoffice is
still building) with pkgsrc-current.


Home | Main Index | Thread Index | Old Index