pkgsrc-Users archive

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index][Old Index]

Re: GCC and as

On 05/12/18 01:15, wrote:
It might be cool to have a single PREFER.toolchain=pkgsrc, introducing
things like this to a particular chosen GCC version:

.if ${PREFER.toolchain} == "pkgsrc"
.  include "../../devel/binutils/"
CONFIGURE_ARGS+=	--with-gnu-as --with-as=${PREFIX}/bin/gas
CONFIGURE_ARGS+=	--with-gnu-ld --with-ld=${PREFIX}/bin/gld

Introduce the relevant GCC_REQD and GFORTRAN_VERSION
Make them required at bootstrap in a way that works

We can keep your favourite GCC version until C++14/C++17 starts to
appear in critical packages.

then test for centos 5 at bootstrap and decide if you want to make it
the default, or maybe test for linux x86 + old binutils.*

(I know is kinda awful...)

* Please solicit opinions before flipping a default, since this is
pretty invasive and there are a few other old-CentOS users.
That sounds like a good idea.  I would suggest turning this on automatically for any Enterprise Linux system, e.g.

.if exists("/etc/redhat-release") || equivalent for SUSE Enterprise || better way to detect old toolchains

RHEL/CentOS 5 is already EOL, BTW.  6 is already showing symptoms and it's probably only a matter of time before we see problems on 7.  Once a RHEL release is branched, the core development utilities never get a major upgrade.
( Security and bug fix patches, yes, but not upgrades. )

RHEL 7 uses gcc 4.8, which is already too old for some packages. I'm configuring all my trees to use gcc5 as a base now and will likely go to gcc6 soon.  binutils is at 2.27, which is actually newer than pkgsrc's 2.26, but in a couple years it will still
be 2.27 and what will the latest gcc packages require?

Home | Main Index | Thread Index | Old Index