pkgsrc-Users archive

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index][Old Index]

Re: libreoffice- install failed

Hi Chevdar,

Thank you, based on your recommendation I could build libreoffice.

These are the steps I've done:

1. Remove xorg-modular and all dependencies
2. Rebuilt a distribution with X11=yes
3. Rebuilt /usr/pkgsrc/pkgtools/osabi
4. Edited /etc/mk.conf, put the line: X11_TYPE=native
5. Rebuilt libreoffice
6. Installed it :)



2018-01-09 17:17 időpontban Chavdar Ivanov ezt írta:

I built successfully the same version under -current some two weeks
ago. I see you are using Xorg from pkgsrc - this is something I
haven't tried for quite some time. My build links to
from /usr/X11R7/lib/.

I would suggest updating that Xorg or building on a host
withoutx11/Xorg packages; I don't know how to force using the in-tree
one (the more that you may not have it installed at all if you use the
pkgsrc version).

Chavdar Ivanov

On 9 January 2018 at 14:33, Fekete Zoltán <> wrote:
Hi There,

I'm trying to build libreoffice- in current. At the install phase
there is a strange message and then the build breaks:

/pkg/bin/gmake VERBOSE=true -f Makefile
Executable_gengal && /usr/sbin/paxctl +m instdir/program/gengal.bin
Automatic fetching of external tarballs is disabled.
/usr/pkg/bin/gmake -j 1 -rs -f
[DEP] LNK:Executable/gengal.bin
[LNK] Executable/gengal.bin
/usr/pkg/lib/ undefined reference to
recipe for target
gmake[1]: ***
Error 1
Makefile:164: recipe for target 'Executable_gengal' failed
gmake: *** [Executable_gengal] Error 2
*** Error code 2

make[1]: stopped in /usr/pkgsrc/misc/libreoffice
*** Error code 1

make: stopped in /usr/pkgsrc/misc/libreoffice

What could be the solution?
Formerly (former versions) all builds worked for me for libreoffice.

Thank you:


Home | Main Index | Thread Index | Old Index