pkgsrc-Users archive

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index][Old Index]

Re: lang/gcc5-aux build hangs on amd64, no reference to PCH


> cd /usr/pkgsrc/*/gcc5-aux
> cvs update -APdC
> make clean # stale work directory will still be broken
> make
> to disable ASLR globally:
> sysctl -w security.pax.aslr.enabled=0

Would disabling ASLR enable gcc-aux and gcc5-aux to build?  Seems strange.

Anyway, I ran, from /BETA1/pkgsrc,
cvs up -dP -A
I don't really know if I need -A, but believe -A is necessary when updating current src tree.

I noticed updaed Makefile in lang/gcc-aux and lang/gcc5-aux.

Having not kept the previous history, I browsed on, found the difference, it was related to PCH.

I noticed no updated Makefile in gcc6-aux but also remember gcc6-aux Makefile excludes NetBSD.

I tried again on gcc5-aux, with "make clean clean-depends" but not disabling ASLR, failed in the same way.

Now I try again with "make clean clean-depends" and "sysctl -w security.pax.aslr.enabled=0", see what happens.

UPDATE: I tried, got the same build log, hung and required Crtl-C to get out, no reference to PCH.  It looks like the culprit is something else.


Home | Main Index | Thread Index | Old Index