pkgsrc-Users archive

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index][Old Index]

Re: Pbulk bootstrap issue

On 05/13/17 12:51, Jason Bacon wrote:
On 05/13/17 12:16, Sevan Janiyan wrote:
On 13/05/2017 17:08, Jason Bacon wrote:
Anybody ever run into an issue like this when bootstrapping pbulk?

Yes, when your toolchain is incomplete.

Why is it trying to execute cc1?
'gcc: error trying to exec 'cc1': execvp: No such file or directory'


cc1 is one of the compile stages invoked by gcc;

bacon ~ 67: strings /usr/local/bin/gcc5 | grep cc1|more
%(cc1_cpu) %{profile:-p}
cc1 -E %{traditional|traditional-cpp:-traditional-cpp}
cc1 -fpreprocessed %{save-temps*:%b.i} %{!save-temps*:%g.i} %(cc1_options)} %{!save-temps*:%{!traditional-cpp:%{!no-integrated-cpp: cc1 %(cpp_unique_options) %(cc1_options)}}} %{!fsyntax-only:%(invoke_as)}}}}

The toolchain is not incomplete. It works fine outside the chroot. The cc1 command is there under $prefix/libexec, but somehow gcc can't find it when I run it in the sandbox. I would have thought that gcc uses rpath to locate cpp, cc1, etc, but this seems to be some sort of odd PATH issue that I'm having a hard time tracking down.



I found a solution, which is not to say I understand the problem. CentOS 7 has a copy of gcc in /bin, same as what's in /usr/bin:

sh-4.2# sha256sum /bin/gcc /usr/bin/gcc
ac85b3edd5c6e318462b6f61d81b3e2a64183827b0ab0f3aa1e0258ba3af030e /bin/gcc
ac85b3edd5c6e318462b6f61d81b3e2a64183827b0ab0f3aa1e0258ba3af030e /usr/bin/gcc

However, /bin/gcc fails with the error in my config.log. After I changed PATH from /usr/pbulk/bin:/bin:/sbin:/usr/bin:/usr/sbin to /usr/pbulk/bin:/usr/bin:/usr/sbin:/bin:/sbin, the bootstrap worked.


Earth is a beta site.

Home | Main Index | Thread Index | Old Index