pkgsrc-Users archive

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index][Old Index]

Re: problem bootstrapping pkgsrc on FreeBSD 11

I did exactly this - to the extent of C/P the lines above - and it worked without a problem. The only difference to the first try was the run under script. Btw the vm is zfs-based, so pkg and pkgsrc are zfs datasets (cleaning /usr/pkg was 'zfs destroy' and 'zfs create'). 

Go figure... 


(well, there was one more difference - with the first try I just in case copied the newly created /usr/pkg/etc/mk.conf to /etc, which did not make difference. I didn't remove this file when I ran the second trial, I wonder if this may have scewed the result).

On Wed, 8 Feb 2017 at 20:07 Sevan Janiyan <> wrote:

On 08/02/2017 20:01, Chavdar Ivanov wrote:
> f11R# uname -a
> FreeBSD f11R.lorien.lan 11.0-RELEASE-p2 FreeBSD 11.0-RELEASE-p2 #0: Mon
> Oct 24 06:55:27 UTC 2016
>  amd64
> f11R# freebsd-version
> 11.0-RELEASE-p7

Can you try to bootstrap once more but log the process & share the log file

rm -rf /usr/pkg
script /tmp/pkgboot.txt
cd /usr/pkgsrc/bootstrap

When the bootstrap completes

cd /usr/pkgsrc/pkgtools/digest
/usr/pkg/bin/bmake clean clean-depends
/usr/pkg/bin/bmake install clean clean-depends

When you run exit, system will stop logging. Share the content of
/tmp/pkgboot.txt to indicate what happened.


Home | Main Index | Thread Index | Old Index