pkgsrc-Users archive

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index][Old Index]

Peculiar problem with kmail on AMD64 current

I have run into a peculiar problem with kmail where it performs fine on one 
AMD64 system and yet the same kernel/userland/packages on other AMD64 
hardware results in kmail crashing when replying or forwarding a mail. 

I built/installed an recent 7.99.21 kernel/userland on a dual processor Dell 
AMD64 system and then built a whole raft of packages (pkgsrc current) and did 
some  basic testing. Pretty much everything worked as expected, including 
sound on kde etc. I  copied the binary packages and config files to two other 
AMD64 systems, a T400 laptop also running 7.99.21 and a quad processor system 
(same release) which is my main desktop system and I spotted the problem on 
the latter. Kmail worked fine for new mails/reading mail, but if you replied 
or forwarded a mail inline it crashed - a segment violation.

Strangely the laptop didn't suffer this problem whatsoever and I assumed some 
slight variation of config files/libraries/etc was triggering an issue in 
kmail on the other systems.

However if I removed the laptop disk and used it to boot the other systems, 
the kmail problem showed up - and now there was no doubt the software was the 

So it would appear that a userland program which should be insulated 
from the underlying hardware by the kernel is being affected by different H/W. 
The only thing kmail is doing is opening a new window under X and no other 
program has shown the problem so I am discounting an issue with the underlying 
X video kit. If a mail was forwarded as an attachment then it worked fine on 
any system so I guess its something to do with memory allocation. The systems 
all have differing amounts of physical memory - the laptop has 3g, the Dell 4g 
and the other system 16g. 

Can anyone suggest what's going on. A pkgsrc build from about a year ago on a  
correspondingly old version of current has worked faultlessly with kmail  
behaving as expected on all three systems... A more recent build of the latest 
current + pkgsrc still shows the same problem on the Dell - but I haven't 
tried moving the disk on the laptop yet.                                                                                                                       

Home | Main Index | Thread Index | Old Index