pkgsrc-Users archive

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index][Old Index]

Re: multimedia/vlc2 fails to compile

On Sat 04 Oct 2014 at 19:22:52 +0100, Patrick Welche wrote:
> Re vlc build failure:
> The following code is run from the modules directory:
>   if test "x86_64--netbsd" = "x86_64--netbsd"; then \
>           ../bin/vlc-cache-gen . ; \
>   else \
>           echo "Cross-compilation: cache generation skipped!" ; \
>   fi
> at which point, vlc-cache-gen dumps core withe a segmentation fault.
> If I manually cd to the modules directory, and run "../bin/vlc-cache-gen .",
> it succeeds and I see no core dump.

Interestingly, I see a slight variation: I see it from the bin
directory, and the command is (the conditional structure is the same)

    ./vlc-cache-gen ../modules

As an experiment, I ran this manually, and stubbed out the command (it
tries to re-run it if I restart make). This lets plain "make" complete.
Unfortunately, when doing "make package" it runs the command again

gmake[3]: Entering directory '/pkg_comp/obj/pkgsrc/multimedia/vlc2/default/vlc-2.0.9'
 autotools/install-sh -c -d '/pkg_comp/obj/pkgsrc/multimedia/vlc2/default/.destdir/usr/pkg/bin'
 /usr/bin/install -c -o root -g wheel -m 755 cvlc rvlc qvlc '/pkg_comp/obj/pkgsrc/multimedia/vlc2/default/.destdir/usr/pkg/bin'
/usr/pkg/bin/gmake  install-exec-hook
gmake[4]: Entering directory '/pkg_comp/obj/pkgsrc/multimedia/vlc2/default/vlc-2.0.9'
if test "x86_64--netbsd" = "x86_64--netbsd"; then \
        LD_LIBRARY_PATH="/pkg_comp/obj/pkgsrc/multimedia/vlc2/default/.destdir/usr/pkg/lib:$LD_LIBRARY_PATH" \
        "/pkg_comp/obj/pkgsrc/multimedia/vlc2/default/.destdir/usr/pkg/lib/vlc/vlc-cache-gen" \
                 "/pkg_comp/obj/pkgsrc/multimedia/vlc2/default/.destdir/usr/pkg/lib/vlc/plugins" ; \
else \
        echo "Cross-compilation: cache generation skipped!" ; \
[1]   Segmentation fault (core dumped) LD_LIBRARY_PATH=...
Makefile:2213: recipe for target 'install-exec-hook' failed
gmake[4]: *** [install-exec-hook] Error 139
gmake[4]: Leaving directory '/pkg_comp/obj/pkgsrc/multimedia/vlc2/default/vlc-2.0.9'

If I disarm this second copy of the command then packaging succeeds.

I haven't tried running it yet, since I haven't updated my pkg
collection yet. (Previous quarter, this crashed after some seconds of

___ Olaf 'Rhialto' Seibert  -- The Doctor: No, 'eureka' is Greek for
\X/ rhialto/at/    -- 'this bath is too hot.'

Attachment: pgpdmbx0l7D3a.pgp
Description: PGP signature

Home | Main Index | Thread Index | Old Index