pkgsrc-Users archive

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index][Old Index]

Re: pkg_add miscalculation for conflicts

Am 22.06.2014 um 17:41 schrieb OBATA Akio <>:
>> pkg_add: Installed package `perl-5.20.0nb1' conflicts with 
>> `p5-ExtUtils-CBuilder<' when trying to install 
>> `p5-ExtUtils-CBuilder-
> It means that you are
>  trying to install `p5-ExtUtils-CBuilder-',
> and
>  Installed package perl-5.20.0nb1' conflicts with 
> `p5-ExtUtils-CBuilder<
> i.e. perl-5.20.0nb1 contains ExtUtils::CBuilder module version,
> and p5-ExtUtils-CBuilder- is older than it, no need to be 
> installed.

Oh, really?  I was under the impression that with perl-5.20.0nb1 you can only 
install p5-ExtUtils-CBuilder versions older than, because newer 
versions rely on perl 5 newer than 5.20...
> Yes, some packages are still older than perl-5.20.0 core modules, so
> those package should be updated to latest version (or removed from pkgsrc).

And, by the way, it was a PITA to upgrade from perl5.18 to perl 5.20 via 
pkg_rolling-replace, essentially, i had to do it by hand by removing any traces 
of some packages via pkg_delete -fN.  the aforementioned was one of those.


Attachment: signature.asc
Description: Message signed with OpenPGP using GPGMail

Home | Main Index | Thread Index | Old Index