pkgsrc-Users archive

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index][Old Index]

Is Firefox 29 supposed to play embedded .mp4 natively?


according to this thread on bugzilla:

Firefox 26 and onwards (at least on Linux) should be able to play .mp4
natively with gst-plugins0.10-good and gst-plugins0.10-ffmpeg.

I am not sure how the above applies to Netbsd, but this is what I have:

$ pkgin list|grep gst
gst-ffmpeg-0.10.13nb7 GStreamer ffmpeg plugin
gst-libav-1.0.10     GStreamer libav/ffmpeg plugin
gst-plugins0.10-base-0.10.36nb7 Open source multimedia framework - Base plugins
gst-plugins0.10-good-0.10.31nb4 Open source multimedia framework - Good plugins
gst-plugins1-base-1.0.10 Open source multimedia framework - Base plugins
gstreamer0.10-0.10.36nb6 Open source multimedia framework
gstreamer1-1.0.10    Open source multimedia framework

And I have media.gstreamer.enabled;true in about:config.

However, testing results here:
I still cannot play mp4 embedded videos in FF.

In the same thread (see above) somebody mentioned that true mp4
support won't be added in FF until Gsteamer 1.0 is built in, which is
supposed to happen in FF 31. So I am a bit confused.

Do I need any more plugins or am I chasing ghosts?



Home | Main Index | Thread Index | Old Index