pkgsrc-Users archive

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index][Old Index]

In preparation of Lua-5.3 - versioned binaries of Lua?


Lua 5.3 is already in an advanced stage of designing and development [1].

Currently we maintain two versions of Lua in pkgsrc: 5.1 and 5.2. However they 
are conflicting, because they install binaries as bin/lua. It prevents me for 
easily using unmodified software designed for Lua 5.1 (like Luapress) in a 
system where the main version is Lua 5.2. The Lua generations 5.1 and 5.2 
aren't fully compatible.

Python packages ships with versioned binaries: python2.6, python2.7, python3.3.

Could we follow the same pattern for Lua? We may be soon ready for inclusion of 
Lua 5.3 without damaging the current Lua ecosystem, as the backward 
compatibility between 5.3 and earlier generations is still unknown.

Additionally, NetBSD ships with bin/lua, so the pkgsrc's version is (more or 
less) hiding it.

With regards,


Home | Main Index | Thread Index | Old Index