pkgsrc-Users archive

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index][Old Index]

Problems to build perl5 on solaris


i have problems to build perl5 on solaris since pkgsrc-2013Q1 - pkgsrc-2013Q4.
I allways get a dtrace related error. Allthrough i unset the package variable 
dtrace i get the same error.

PKG_OPTIONS.perl = 64bitauto threads

LD_LIBRARY_PATH=/usr/pkgsrc/lang/perl5/work/perl\-5.18.1 cc -pthread  
-L/usr/lib -Wl,-R/usr/lib -Wl,-R/opt/pkg/lib -L/usr/ccs/lib 
-L/opt/solstudio12.2/prod/lib -L/lib -L/opt/local/lib -o miniperl  perlmini.o 
opmini.o miniperlmain.o   gv.o toke.o perly.o pad.o regcomp.o dump.o util.o 
mg.o reentr.o mro.o keywords.o hv.o av.o run.o pp_hot.o sv.o pp.o scope.o 
pp_ctl.o pp_sys.o doop.o doio.o regexec.o utf8.o taint.o deb.o universal.o 
globals.o perlio.o perlapi.o numeric.o mathoms.o locale.o pp_pack.o pp_sort.o   
-lm -ldl -lsocket -lnsl -lpthread -lrt
Undefined                       first referenced
 symbol                             in file
__dtrace_perl___loaded__file        pp_ctl.o
__dtraceenabled_perl___op__entry    dump.o
__dtrace_perl___sub__entry          pp_hot.o
__dtraceenabled_perl___phase__change perlmini.o
__dtraceenabled_perl___loaded__file pp_ctl.o
__dtrace_perl___phase__change       perlmini.o
__dtraceenabled_perl___sub__return  pp_hot.o
__dtrace_perl___op__entry           dump.o
__dtraceenabled_perl___loading__file pp_ctl.o
__dtraceenabled_perl___sub__entry   pp_hot.o
__dtrace_perl___sub__return         pp_hot.o
__dtrace_perl___loading__file       pp_ctl.o
ld: fatal: symbol referencing errors. No output written to miniperl

I have the same error with gcc or sunstudio cc.

It seems that unset the package variable doesn't unset the configure option 
dtrace in the build process (i still see dtrace set inside work).

It works for me if i run Configure manually after bmake configure.


i comment some lines in out (incl. PKG_OPTIONS.perl w/o dtrace)
.if !empty(PKG_OPTIONS:Mdebug)
CFLAGS+=                -DDEBUGGING

#.if !empty(PKG_OPTIONS:Mdtrace)
#CONFIGURE_ARGS+=       -Dusedtrace
# perldtrace.h has incorrect dependencies, needs to be built first.
#BUILD_TARGET=          perldtrace.h all

.if !empty(PKG_OPTIONS:Mmstats)
CONFIGURE_ARGS+=        -Dusemymalloc
CONFIGURE_ARGS+=        -Uusemymalloc

Than it works for me.

Greetings Stephan

Home | Main Index | Thread Index | Old Index