pkgsrc-Users archive

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index][Old Index]

Re: Re: How to build a package when earlier versions of dependencies are already installed?

> > Stop.
> > make: stopped in /BETA1/pkgsrc/x11/modular-xorg-server
> > *** Error code 1

> > Stop.

> > Just before all this, I had run
> > pkg_rolling-replace -suv

> > so I shouldn't have had these silly snags.

> > Now I don't even know what version of modular-xorg I have.
> > How do I get pkgsrc system to update the dependency packages instead of 
> > stopping there?

> I'd say, pkgtools/pkg_rolling-replace or pkgtools/pbulk is your friend.
> Different flavours - but both can make you happy.
> Cheers
> Jens Rehsack
> pkgsrc, Perl5

I include an excerpt from my original post: I had already run
pkg_rolling-replace -suv
just before.

You weren't reading carefully enough.

I guess pkg_rolling-replace only worked partially?

I guess I should have posted my file /etc/mk.conf :
(UPDATE_TARGET line is a subsequent addition.)

.ifdef BSD_PKG_MK       # begin pkgsrc settings

PACKAGES= /usr/packages
# PKG_DEFAULT_OPTIONS+= ssl inet6 ncurses pcre
PKG_DEFAULT_OPTIONS+= ssl inet6 cups esound ncurses sndfile gtk2 x11 fftw pcre
PKG_DBDIR=              /var/db/pkg
LOCALBASE=              /usr/pkg
VARBASE=                /var
PKG_TOOLS_BIN=          /usr/pkg/sbin
PKGMANDIR=              man
WRKDIR_BASENAME=        work6.i386
WRKOBJDIR=              /BETA1/pkgsrc
PKG_OPTIONS.msmtp+= idn 
PKG_OPTIONS.lynx+= ncurses 
ACCEPTABLE_LICENSES+= socks5-license

.endif                  # end pkgsrc settings


Home | Main Index | Thread Index | Old Index