pkgsrc-Users archive

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index][Old Index]

build postfix chokes on mysql4 ??

running NetBSD:

NetBSD mail 5.0.2 NetBSD 5.0.2 (MAIL) #5: Tue Apr 26 17:38:29 PDT 2011  
root@mail:/usr/src/BUILD_OBJ/sys/arch/i386/compile/MAIL i386

In a chroot'd environment, which seemed to work well until I moved to pkgsrc 

I have cvs updated  pkgsrc HEAD several times over the past few days (since I 
started seeing this).

Same results regardless  of whether I have installed mysql51, 55 or 56.

I'm having a little trouble understanding this:

# (cd mail/postfix && make  show-options)
Any of the following general options may be selected:
        bdb      Enable Berkeley DB support.
        ldap     Enable LDAP support.
        mysql    Enable MySQL support.
        pcre     Enable Perl-compatible regular expressions.
        pgsql    Enable PostgreSQL support.
        sasl     Enable SASL support.
        sqlite   Enable SQLite support.
        tls      Enable TLS support.

These options are enabled by default:

These options are currently enabled:
        bdb pcre pgsql sasl tls

You can select which build options to use by setting PKG_DEFAULT_OPTIONS
or PKG_OPTIONS.postfix.

# (cd mail/postfix && make  clean install)
===> Cleaning for postfix-2.9.6
ERROR: This package has set PKG_FAIL_REASON:
ERROR: [] The following selected options are not supported: 
*** Error code 1

make: stopped in /usr/pkgsrc/mail/postfix

In /etc/mk.conf I have tried several version of /etc/mk.conf:

Variant 1:

PKG_OPTIONS.postfix += tls pcre sasl mysql
PKG_OPTIONS.postfix += -ldap

Variant 2:

PKG_OPTIONS.postfix += tls pcre sasl -mysql
PKG_OPTIONS.postfix += -ldap

Variant 3:

PKG_OPTIONS.postfix += tls mysql pcre sasl
PKG_OPTIONS.postfix += -ldap

Variant 4:

PKG_OPTIONS.postfix += tls pcre sasl -mysql4
PKG_OPTIONS.postfix += -ldap

I've tried to track down where the 4 comes from with no luck.


Home | Main Index | Thread Index | Old Index