pkgsrc-Users archive

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index][Old Index]

Re: polyml 5.5 build fails Xm/Xm.h missing

Saifi Khan <> writes:

> On Sun, 28 Oct 2012, Bernd Ernesti wrote:
>> On Sun, Oct 28, 2012 at 07:37:18AM +0530, Saifi Khan wrote:
>>> Hi:
>>> Compiling polyml 5.5 libpolyml library using bmake without openmotif 
>>> support, causes the build to fail.
>>> Even though openmotif is installed on my NetBSD-current system, i donot 
>>> wish to build support for openmotif in polyml. Please see the 
>>> PKG_OPTIONS.polyml settings below.
>> Which is wrong.
>> Please check pkgsrc/lang/polyml/ for the correct name
>> for the motif build option. Hint openmotif is not the only motif
>> in pkgsrc, there is lesstif too so a openmotif option is usally
>> not correct.
>> Btw you do not need to add x11 since that is the default you
>> only need to add the options which should overwritte others.
>> Bernd
> Hi Bernd:
> Thank you for your kind reply.
> There is a typo in the mail as i typed the PKG_OPTIONS.polyml option line
> However, it looks thus
>  PKG_OPTIONS.polyml= x11 -motif
> The build failed with the above options.

I've checked the source, Motif is required when using X11 support.
I'll remove the option.

> In fact, when i disabled both the options,
>  PKG_OPTIONS.polyml= -x11 -motif
> The build still failed with the error
> 'ld: final link failed: bad value'.
> i have posted a separate mail on pkgsrc-users about that.

You will make life easier if we don't need to search for a separate mail
(I haven't found it) and don't need to ask you to provide more details.
It is not clear from your mail which port you're using, it is not clear
which command failed, and so on.


Home | Main Index | Thread Index | Old Index