pkgsrc-Users archive

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index][Old Index]

Re: core dump sysutils/sysupgrade


Looks like I was successful ....
but It looks modules are not being installed.
What should I do?

2012/10/24 Jeremy C. Reed <>:
> On Tue, 23 Oct 2012, ???( Miwa Susumu ) wrote:
>> I use sysutils/sysupgrade, tried to update 5.1 to 6.0.
> ...
>> sysupgrade: I: Skipping modules installation (modules not in SETS)
>> sysupgrade: I: Upgrading kernel using GENERIC in /
>> sysupgrade: I: Backing up 'netbsd' kernel as 'onetbsd'
> Shouldn't it reboot here using the a new major kernel?

I've run one at a time step of "sysupgrade auto".
Quote from "man sysupgrade"

   The auto command
     The standard upgrade procedure performed by this command is as follows:

     1.   `fetch': Retrieve distribution sets into the local cache directory.

     2.   `modules': Unpack new kernel modules.

     3.   `kernel': Upgrade kernel.

     4.   `sets': Upgrade system sets, except configuration files.

     5.   `etcupdate': Merge new changes to configuration files.  This is the
          only interactive step in the process and can be disabled for this
          reason by setting ETCUPDATE to false.

     6.   `postinstall': Perform sanity checks and optionally apply
          unconditional fixes to the upgraded system.

     7.   `clean': Remove contents of the cache directory.  This can be
          disabled by setting AUTOCLEAN to false in case you want to keep the
          downloaded distribution files around.

Looks like I was successful ....

# sysupgrade fetch
# sysupgrade kernel
# reboot

but I got an error running sysupgrade modules, after reboot.

# sysupgrade modules
sysupgrade: I: Skipping modules installation (modules not in SETS)

I will continue as it is for now.

# sysupgrade sets
# sysupgrade etcupdate
# sysupgrade postinstall
# sysupgrade clean

I reboot again (somehow) , I ran sysupgrade auto.

# sysupgrade auto

There was no error in particular.

# uname -a
NetBSD 6.0 NetBSD 6.0 (GENERIC) i386

however modules of 6.0 does not exist.

# ls  /stand/i386/


>> sysupgrade: I: Upgrading base system
>> sysupgrade: I: Extracting base into /
>> 100% 
>> |****************************************************************************************************************************|
>>    99 MiB    5.54 MiB/s    00:00 ETA
>> sysupgrade: I: Extracting comp into /
>> [1]   Bad system call (core dumped) progress -zf "${...
> Maybe it should use previous /rescue/tar if not rebooting? But what
> about progress?

I was successful after reboot. ( looks like ...)


Home | Main Index | Thread Index | Old Index