pkgsrc-Users archive

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index][Old Index]

Can we get rid of fvwm1?


While looking at upgrading fvwm to the latest 2.6.x release, I found
that the package is way more complicated than it should be due to the
fact that we attempt to allow the installation of the old fvwm1 along
the newer 2.x versions.  I could understand the need for this years
ago, but not today.

So, questions:

1) Can we remove fvwm1?  If not, why not?  (Note that the fvwm1 package
depends on the xpmroot tool that comes with fvwm 2.x... so this is

2) If we cannot remove fvwm1, could we move the "hacks" to support
coexistence into the fvwm1 package to keep the newer fvwm package
leaner (and thus easier to maintain)?  In particular, that'd mean
renaming a few of the installation directories to fvwm1.


Home | Main Index | Thread Index | Old Index