pkgsrc-Users archive

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index][Old Index]

Re: [HEADS UP] cairo downgraded

> On Tue, Oct 09, 2012 at 04:51:40AM -0400, Thomas Mueller wrote:
>  > >  > I've updated cairo to 1.12.4 yesterday, but it causes problems on OS X
>  > >  > Lion and NetBSD (too old Xserver, I guess), so I had to revert it.

>  > > FTR, it also doesn't build on netbsd-5; the SHM stuff needs to be
>  > > disabled.

>  > > This is not because netbsd-5's native X doesn't have the SHM
>  > > extension, which is one of the older X extensions around; it's because
>  > > x11-links is broken.

>  > Use modular (pkgsrc) Xorg instead of native?  That would get around the
>  > problem of x11-links, which was a never-ending source of problems building
>  > packages from pkgsrc.  Then maybe current version of graphics/cairo would
>  > work right?

> It might, but taking that route officially would amount to abandoning
> support for native X on netbsd-5, which is not something I think we're
> ready to do.

> --
> David A. Holland

Does OS X Lion also use NetBSD-style native X that requires x11-links?

Is there any way to keep two versions of graphics/cairo, one for native X
and the other for modular Xorg?  Maybe there could be instructions in the
Makefile telling it to avoid the new version if XORG_TYPE is native as opposed
to modular?  Or is that too complicated and error-prone?

Pkgsrc users on non-NetBSD OSes might not like being held back on
graphics/cairo because of something awry with x11-links.

Is x11-links repairable?

Many users of NetBSD 5.x may be deep into native X with many packages built
based on native X.  netbsd-6 and HEAD still haven't been released.


Home | Main Index | Thread Index | Old Index