pkgsrc-Users archive

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index][Old Index]

Re: DEPENDS foo OR bar?


On Sat, 23 Jun 2012 03:37:07 +0900, matthew sporleder 
<> wrote:

I recently ran into p5-CGI-Session requiring a slightly newer p5-JSON
then I had installed.

I -think- perl 5.14.2 has the new-enough version, but I have 5.14.1,
which doesn't.

How do I DEPEND on a newer p5-JSON OR a newer perl?

You can use like a following scheme:
DEPENDS+=       {perl>=5.14.2,p5-JSON>=2.53}:../../converters/p5-JSON

But I cannot find JSON module in perl core

 % corelist JSON

 JSON was not in CORE (or I think)

I can only find JSON::PP

 % corelist -a JSON::PP

 JSON::PP was first released with perl v5.13.9
   v5.13.9    2.27103
   v5.13.10   2.27103
   v5.13.11   2.27105
   v5.14.0    2.27105
   v5.14.1    2.27105
   v5.14.2    2.27105

No version differ from 5.14.1 and 5.14.2.

OBATA Akio /

Home | Main Index | Thread Index | Old Index