pkgsrc-Users archive

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index][Old Index]

pkgsrc math/octave fails to build with recent NetBSD-current


I wonder if this error may be related to recent library changes. Thus, the 
current-users' copy.

With NetBSD 6.99.4 I get the following error when building math/octave:

fflush.c: In function 'update_fpos_cache':
fflush.c:110:16: error: incompatible types when assigning to type '__off_t' 
from type 'fpos_t'

The code in question is:

static inline void
update_fpos_cache (FILE *fp, off_t pos)
#if defined __sferror || defined __DragonFly__ /* FreeBSD, NetBSD, OpenBSD, 
onFly, MacOS X, Cygwin */
# if defined __CYGWIN__
  /* fp_->_offset is typed as an integer.  */
  fp_->_offset = pos;
# else
  /* fp_->_offset is an fpos_t.  */ 
  /* Use a union, since on NetBSD, the compilation flags determine
     whether fpos_t is typedef'd to off_t or a struct containing a
     single off_t member.  */
      fpos_t f;
      off_t o;
    } u;
  u.o = pos;
  fp_->_offset = u.f; 
# endif
  fp_->_flags |= __SOFF;

and line 110 is the "fp_->_offset = u.f;" assignment.

Anyone knows how best to fix this?


Home | Main Index | Thread Index | Old Index