pkgsrc-Users archive

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index][Old Index]

Re: firefox build error after upgrade to 6.0_beta

On Tue, Feb 21, 2012 at 12:32:19AM +0530, Mayuresh wrote:
> On Mon, Feb 20, 2012 at 07:54:35PM +0100, Martin Husemann wrote:
> > Did you rebuild x11-links?
> > 
> > Martin
> Tried building now. If I set x11 to modular I get the following error:
> ERROR: x11-links-0.68 should only be used with X11_TYPE=native.

Dumped modular and started rebuilding. Face following dependency error no:

configure: error: Library requirements (gtk+-2.0 >= 2.10.0
gtk+-unix-print-2.0 glib-2.0 gobject-2.0 gdk-x11-2.0) not met; consider
adjusting the PKG_CONFIG_PATH environment variable if your libraries are
in a nonstandard prefix so pkg-config can find them.
*** Error code 1

Following shows what is already installed. Am I missing something?
It shows gtk+-1.2. Above message shows gtk+-2.0. How do I satisfy this

# pkg_info | grep gtk
gtk-doc-1.18        Tools for authors of the GTK+ reference documentation
gtk2+-2.24.10       GIMP Toolkit v2 - libraries for building X11 user
gtk+-1.2.10nb10     GIMP Toolkit v1 - libraries for building X11 user
gdk-pixbuf2-2.24.1nb2 Image loaders for gtk2
gtk3+-3.2.3nb2      GIMP Toolkit v3 - libraries for building X11 user
gtk+extra-0.99.17nb6 Useful set of GTK+ widgets for creating GUIs
py26-gtk2-2.24.0nb3 Python bindings for GTK+2

Home | Main Index | Thread Index | Old Index