pkgsrc-Users archive

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index][Old Index]

Re: Rearranging Samba packages

Roy Marples <> writes:

> On Sat, 2011-12-10 at 01:04 +0400, Aleksej Saushev wrote:
>> I'm testing Samba 3.6.1 and would like to rearrange packages so that
>> net/samba would be the latest stable release rather than the oldest as
>> it is now. This means in particular that:
>> a) net/samba which is Samba 3.0.37 becomes net/samba30;
>> b) net/samba35 which is Samba 3.5.11 becomes net/samba to be updated to
>> Samba 3.6.1 soon (or later 3.6, if it happens in the middle).
>> Objections?
> Why not follow the postgresql approach?
> Then users get want they want and don't have to upgrade until their
> locked version is removed from pkgsrc due to us or upstream no longer
> supporting it.

Why follow it? PostgreSQL "approach" is a necessity since you didn't
have easy upgrade path until very recently. (And even now it isn't as
easy that you could just update, you still have to plan migration.)


Home | Main Index | Thread Index | Old Index