pkgsrc-Users archive

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index][Old Index]

New dependency to gcc 3


While trying to update wip/libreoffice to a newer snapshot, I have been
bitten by a dependency to gcc-3 which appeared overnight.

  $ bmake extract
  => Full dependency gcc3-c>=3.3.5nb1: NOT found
  => Verifying package-install for ../../lang/gcc3-c
  ERROR: This package is not available for these platforms: Darwin-*-*
  Interix-*-* DragonFly-*-*.
  ERROR: This package has set PKG_FAIL_REASON:
  ERROR: gcc3-c-3.3.6nb1 is not available for DragonFly-2.11-x86_64
  *** Error code 1

The package doesn't ask for a specific gcc version and strangely, pkgsrc
does not seem to take into account the system versions of gcc 4.x which are
already installed on the machine

Before trying to unpack the distfiles, I updated pkgsrc to the latest version
of the 2011Q2 branch.
Has the handling of the compiler been changed recently ? This is really

Francois Tigeot

Home | Main Index | Thread Index | Old Index