pkgsrc-Users archive

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index][Old Index]

Re: apcupsd-3.14.3nb3 does not build with net-snmp-

> With pkgsrc updated last Sunday, I've been trying to bring my systems up to 
> current versions of everything.  Other than an earlier-reported issue with 
> Samba (which I can live without!), I've got everything rebuild....
> .... except for sysutils/apcupsd
> This used to build fine with net-snmp-5.4.3nb3 but with the newer version of 
> net-snmp-5.6.1 I get the following errors:
> c++ -c -I/usr/pkg/include -I/usr/include -I/usr/local/include -fno-exceptions 
> -fno-rtti -O2 -I/usr/pkg/include -I/usr/include -Wall -pthread  
> -I/build/pkgsrc/sysutils/apcupsd/work.x86_64/apcupsd-3.14.3/include   
> powernet-mib-mgr.c
> snmp.h:82: error: expected unqualified-id before numeric constant
> snmp.h:82: error: abstract declarator 'void*' used as declaration
> snmp.h:82: error: expected ';' before numeric constant

I guess the package should be updated. The newest release has a "New SNMP 
driver that no longer requires net-snmp shared libraries."
Manuel, are you planning the update, or should I take a look at it? :)

Kind regards,

Home | Main Index | Thread Index | Old Index